Applies to
All Desktop Client version.
Symptoms or Error
In certain cases installing or uninstalling desktop client fails. Below would be the one of the error message for the failure.
a. Other version of the software is already installed.
b. Error while registering service (-1).
c. Component is already registered.
d. Can not load FSDCAssistant.dll - -1
e. This setup will perform an upgrade. Do you want to continue?
a. Other version of the software is already installed.
If you are presented by below prompt while installing Desktop Client, refer below steps to troubleshoot.
Cause:
This is the known issue with Windows 10 OS. The following registry key does not to get removed on uninstallation.
HKEY_LOCAL_MACHINE\SOFTWARE\<Wow6432Node>\Microsoft\Windows\CurrentVersion\Uninstall\{DCD8999F-7A5D-4645-B4FE-56AC77F32F66}
Resolution:
Please use Desktop Client installer version 2.50.0.0 and above for Windows 10. Please get in touch with support team(support@seclore.com) for latest installer.
If above resolution does not work, refer last section of this article.
b. Error while registering service (-1)
If you are presented by error prompt "Error while registering service (-1)" while installing Desktop Client, refer below steps to troubleshoot.
Cause:
Desktop Client registers below two services during installation and if any unexpected error occurred while registering then it will prompt the error
"Error while registering service (-1)".
This can happen if the service does not get removed post uninstallation of Desktop Client, probable cause system has not been rebooted after uninstallation.
Resolution:
1. Gather below logs
- Application & System Event Viewer logs ()
- Desktop Client Logs ()
- Desktop Installer logs ()
2. Share the logs support team(support@seclore.com) and refer last section for installation cleanup.
c. Component is already registered.
While installing Desktop Client if you are presented with "Component is already registered.", refer below steps to troubleshoot.
Cause:
If the following registries are already present then the installation fails during registering Desktop Client components.
64-bit:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Seclore\FileSecure\Desktop Client
for
32-bit:
HKEY_LOCAL_MACHINE\SOFTWARE\Seclore\FileSecure\Desktop Client
Resolution:
1. Gather below logs
- Application & System Event Viewer logs ()
- Desktop Client Logs ()
- Desktop Installer logs ()
2. Share the logs support team(support@seclore.com) and refer last section for installation cleanup.
d. Can not load FSDCAssistant.dll - -1
While uninstalling Desktop Client if you are presented with "Can not load FSDCAssistant.dll - -1", refer below steps to troubleshoot.
Cause:
If the FSDCAssistant.dll file is missing or corrupted in the Desktop Client installation folder then it will throw the above error.
Resolution:
1. Gather below logs
- Application & System Event Viewer logs ()
- Desktop client installation folder.
- Desktop Client Logs ()
- Desktop Installer logs ()
- Upgrade Logs
2. Share the logs support team(support@seclore.com) and refer last section for installation cleanup.
e. This setup will perform an upgrade. Do you want to continue?
While installing Desktop Client if you are presented with "This setup will perform an upgrade. Do you want to continue?", refer below steps to troubleshoot.
Cause:
If the following registries are already present then the installation will not start and get interrupted with above error.
HKEY_CLASSES_ROOT\Installer\Products\F9998DCDD5A754644BEF65CA773FF266
or
HKLM\SOFTWARE\<Wow6432Node>\Microsoft\Windows\CurrentVersion\Uninstall\{DCD8999F-7A5D-4645-B4FE-56AC77F32F66}
Manual Clean up
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Seclore cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it. Make sure you involve Seclore support executive before carrying this steps and gather necessary info like screenshot and required logs.
Steps:
1. Uninstall Seclore Desktop client from Add/Remove Program if any find it already installed.
2. Locate and rename the Desktop Client installation folder, if there is any.
for 64-bit:
C:\Program Files (x86)\Seclore\FileSecure\Desktop Client
for 32-bit:
C:\Program Files\Seclore\FileSecure\Desktop Client
3. Rename below registry if already present.
a.
HKEY_CLASSES_ROOT\Installer\Products\F9998DCDD5A754644BEF65CA773FF266
b.
for 64-bit
HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{DCD8999F-7A5D-4645-B4FE-56AC77F32F66}
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Seclore\FileSecure\Desktop Client
for 32-bit
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{DCD8999F-7A5D-4645-B4FE-56AC77F32F66}
HKEY_LOCAL_MACHINE\SOFTWARE\Seclore\FileSecure\Desktop Client
4. Delete the Seclore Desktop client services from Microsoft Service console, if any.
a. Launch cmd with admin rights to delete services.
b. Enter following command one by one.
sc delete FileSecureDesktopClientService
sc delete UpgradeService
Important:
Once the above steps are completed, reboot the system. Post reboot recheck the above points and make sure they are not recreated on restart. Now you may proceed with fresh Desktop Client installation.
Please connect with Seclore Support for any queries or assistance required.
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