Issue
When a user tries to sign in to the Seclore Desktop Client, the following error appears:
User authentication failed (-10600000)
Symptoms
- The Desktop Client fails to authenticate the user.
- In the
FSDCTray.log, you see errors indicating issues retrieving discovery cache files from the Policy Server: 2025-11-17T18:32:07.044+05:30 : INTERR : HTTPSession.cpp(827) | ErrorCode : -105064 : Invalid server response. 2025-11-17T18:32:07.911+05:30 : INFO : HTTPSession.cpp(821) | Return system error by WinHttpReceiveResponse() : 12152 2025-11-17T18:32:07.911+05:30 : INTERR : HTTPSession.cpp(827) | ErrorCode : -105064 : Invalid server response. 2025-11-17T18:32:07.911+05:30 : INTERR : HTTPSession.cpp(509) | ErrorCode : -105065 : Failed to send request. 2025-11-17T18:32:07.911+05:30 : ERROR : PSSessionImpl.cpp(167) | Error in getting HttpResponse. 2025-11-17T18:32:07.911+05:30 : ERROR : AuthDiscovery.cpp(53) | Error while getting Discovery from PolicyServer 2025-11-17T18:32:07.911+05:30 : ERROR : PSSessionImpl.cpp(53) | Error in PSSession construction caught Internal Exception. 2025-11-17T18:32:07.911+05:30 : ERROR : PSSessionModuleImpl.cpp(111) | Error in CPSSessionModule::createPSSession caught Internal exception 2025-11-17T18:32:07.911+05:30 : INTERR : LoginService.cpp(163) | Error in checking if OAuthSupported(-105065) 2025-11-17T18:32:07.911+05:30 : INTERR : LoginService.cpp(100) | Error while getting Oauthstatus 2025-11-17T18:32:07.911+05:30 : INTERR : LoginService.cpp(115) | Error while Initializing Login Service. -10600000 2025-11-17T18:32:07.911+05:30 : ERROR : FSDCInterfaceLibExt.cpp(1227) | Error (-10600000) : Failed to Initialize LoginService 2025-11-17T18:32:07.911+05:30 : ERROR : FSDCTrayUtil.cpp(153) | (Default locale) -107593 : User authentication failed (-10600000).
- When testing with Fiddler (on admin-less agent), the server returns HTTP 504 Gateway Timeout and sends 0-byte response instead of discovery cache files.

Root Cause
The Desktop Client cannot retrieve authentication discovery cache files from the Policy Server. These files are required for initializing the login service.
Cache file locations:
C:\ProgramData\Seclore\FileSecure\Desktop Client\<username>\Discovery\AuthDiscoveryC:\ProgramData\Seclore\FileSecure\Desktop Client\administrator\Discovery\PolicyServerDiscovery
Workaround
Copy the missing cache files from a working machine to the same directories on the non-working machine